This series fixes problems with IO priority values handling and cleans
up several macro names and code for clarity.
Changes from v1:
* Added patch 4 to unify the default priority value used in various
places.
* Fixed patch 2 as suggested by Bart: remove extra parenthesis and move
ioprio_valid() from the uapi header to the kernel header.
* In patch 2, add priority value masking.
Damien Le Moal (4):
block: bfq: fix bfq_set_next_ioprio_data()
block: fix ioprio interface
block: rename IOPRIO_BE_NR
block: fix default IO priority handling
block/bfq-iosched.c | 10 +++++-----
block/bfq-iosched.h | 4 ++--
block/bfq-wf2q.c | 6 +++---
block/ioprio.c | 9 ++++-----
drivers/nvme/host/lightnvm.c | 2 +-
fs/f2fs/sysfs.c | 2 +-
include/linux/ioprio.h | 22 ++++++++++++++++++----
include/uapi/linux/ioprio.h | 23 +++++++++++++----------
8 files changed, 47 insertions(+), 31 deletions(-)
--
2.31.1