Re: [PATCH 01/11] mmc: core: Drop open coding when preparing commands with busy signaling
From: Linus Walleij <hidden>
Date: 2021-05-06 12:50:34
Also in:
linux-mmc, lkml
From: Linus Walleij <hidden>
Date: 2021-05-06 12:50:34
Also in:
linux-mmc, lkml
On Tue, May 4, 2021 at 6:12 PM Ulf Hansson [off-list ref] wrote:
Similar code for validating the host->max_busy_timeout towards the current command's busy timeout, exists in mmc_do_erase(), mmc_sleep() and __mmc_switch(). Let's move the common code into a helper function. Signed-off-by: Ulf Hansson <redacted>
This is a really nice refactoring in its own right. Reviewed-by: Linus Walleij <redacted> Yours, Linus Walleij