On 9 Jan 2019, at 11:00, Matthew Wilcox wrote:
On Tue, Jan 08, 2019 at 09:56:29AM -0700, Jens Axboe wrote:
quoted
After some arm twisting from Christoph, I finally caved and divorced
the
aio-poll patches from aio/libaio itself. The io_uring interface
itself
is useful and efficient, and after rebasing all the new goodies on
top
of that, there was little reason to retail the aio connection.
Hence io_uring was born. This is what I previously called scqring for
aio, but now as a standalone entity. Patch #5 adds the core of this
interface, but in short, it has two main data structures:
Please can we call it something that looks a little less like
io_urine?
aio_ring? io_ring? ring_io?
We must be using the same fonts, I've been harassing Jens with jokes
about this for days. But, I totally missed the link between io_uring
and https://twitter.com/axboe/status/927571366085246976 until just now.
It's clear that Jens has been planning this for over a year, and he was
just waiting for us to catch on.
Really though, io_uring is growing on me. The kernel is full of rings
and it does help set it apart.
-chris