Re: [PATCH 1/7] ѕd: split sd_setup_discard_cmnd
From: Bart Van Assche <hidden>
Date: 2017-03-27 22:24:47
Also in:
linux-ide, linux-scsi
From: Bart Van Assche <hidden>
Date: 2017-03-27 22:24:47
Also in:
linux-ide, linux-scsi
On Mon, 2017-03-20 at 16:43 -0400, Christoph Hellwig wrote:
+ u64 sector =3D blk_rq_pos(rq) >> (ilog2(sdp->sector_size) - 9); + u32 nr_sectors =3D blk_rq_sectors(rq) >> (ilog2(sdp->sector_size) - 9);
Although I know this is an issue in the existing code and not something introduced by you: please consider using logical_to_sectors() instead of open-coding this function. Otherwise this patch looks fine to me. Thanks, Bart.