Re: [PATCH 1/7] ѕd: split sd_setup_discard_cmnd
From: "axboe@kernel.dk" <axboe@kernel.dk>
Date: 2017-03-28 14:05:09
Also in:
linux-ide, linux-scsi
From: "axboe@kernel.dk" <axboe@kernel.dk>
Date: 2017-03-28 14:05:09
Also in:
linux-ide, linux-scsi
On Mon, Mar 27 2017, Bart Van Assche wrote:
On Mon, 2017-03-20 at 16:43 -0400, Christoph Hellwig wrote:quoted
+ u64 sector = blk_rq_pos(rq) >> (ilog2(sdp->sector_size) - 9); + u32 nr_sectors = blk_rq_sectors(rq) >> (ilog2(sdp->sector_size) - 9);Although I know this is an issue in the existing code and not something introduced by you: please consider using logical_to_sectors() instead of open-coding this function. Otherwise this patch looks fine to me.
The downside of doing that is that we still call ilog2() twice, which sucks. Would be faster to cache ilog2(sector_size) and use that in the shift calculation. -- Jens Axboe