On Mon, Mar 9, 2026 at 12:00 PM Yu-Chun Lin [林祐君]
[off-list ref] wrote:
quoted
quoted
Therefore, changing this property name will not break any existing
device support in the mainline tree.
Yeah, but will break all other users.
Best regards,
Krzysztof
I understand your concern. I will drop the property rename and keep
realtek,duty-cycle, but I will update its description in v3 to make it clearer.
Hi Linus,
Although you agreed with the rename to realtek,pulse-width-adjust in v1, I
will revert to the original name realtek,duty-cycle to strictly respect the
DT backward compatibility rules. I hope this is fine with you.
Sure, it would also be possible to support both, but that is maybe
a bit messy. Let's go with the old.
Yours,
Linus Walleij