On Thu Dec 11, 2025 at 5:38 PM CET, Kory Maincent (TI.com) wrote:
Remove the "external_" prefix from encoder and connector members in the
tilcdc driver. These are internal driver structures and the "external"
naming is misleading. The simpler names better reflect that these are
the primary encoder and connector managed by this driver.
Also rename tilcdc_attach_external_device() to tilcdc_encoder_create()
for consistency and to better describe the function's purpose.
Signed-off-by: Kory Maincent (TI.com) <kory.maincent@bootlin.com>
[...]
quoted hunk ↗ jump to hunk
@@ -65,13 +65,13 @@ int tilcdc_attach_external_device(struct drm_device *ddev)
else if (ret)
return ret;
- priv->external_encoder = devm_kzalloc(ddev->dev,
- sizeof(*priv->external_encoder),
- GFP_KERNEL);
- if (!priv->external_encoder)
+ priv->encoder = devm_kzalloc(ddev->dev,
+ sizeof(*priv->encoder),
+ GFP_KERNEL);
It would be nice to rewrap this and other lines that would now probably fit
in 100 chars. But not that important, so with or without that:
Reviewed-by: Luca Ceresoli <luca.ceresoli@bootlin.com>
--
Luca Ceresoli, Bootlin
Embedded Linux and Kernel engineering
https://bootlin.com