On Wed, Jun 25, 2025 at 03:43:08AM +0000, Tian, Kevin wrote:
quoted
From: Nicolin Chen <redacted>
Sent: Monday, June 16, 2025 2:47 PM
quoted
Leave other logics to the patches that introduce
ops->hw_queue_init? I guess that would make this patch more readible.
The patch is doing in the way to support the hw_queue_init_phys
case only. It is just adding some extra FIXMEs as the guideline
for the future patch adding hw_queue_init op.
I personally don't feel these are confusing. Maybe you can help
point out what specific wording feels odd here? Maybe "FIXME"s
should be "TODO"s?
I could also drop all of these guideline if they are considered
very unnecessary.
Probably you can put some info in the function comment instead
of being scattered in the code? anyway when the 2nd method
is added in future we'll review and make sure it aligned with the
caveat here. 😊
Yea, probably can drop them. I think AMD will figure it out easily :)
Thanks
Nicolin