Thread (77 messages) 77 messages, 5 authors, 2025-06-26

Re: [PATCH v6 08/25] iommufd/viommu: Add driver-defined vDEVICE support

From: Jason Gunthorpe <jgg@nvidia.com>
Date: 2025-06-19 11:44:48
Also in: linux-doc, linux-iommu, linux-kselftest, linux-patches, linux-tegra, lkml

On Thu, Jun 19, 2025 at 10:26:28AM +0000, Pranjal Shrivastava wrote:
quoted
+struct iommufd_vdevice {
+	struct iommufd_object obj;
+	struct iommufd_viommu *viommu;
+	struct device *dev;
+	u64 id; /* per-vIOMMU virtual ID */
Nit: Why not call this viommu_id?
And lets have a comment here too, we have so many different ids, what
id is this id and what it is used for, by who.

Jason
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help