Thread (31 messages) 31 messages, 2 authors, 2025-01-07

Re: [PATCH v4 03/14] iommufd/fault: Move iommufd_fault_iopf_handler() to header

From: Baolu Lu <baolu.lu@linux.intel.com>
Date: 2025-01-06 02:51:02
Also in: linux-doc, linux-iommu, linux-kselftest, linux-patches, lkml

On 1/4/25 03:43, Nicolin Chen wrote:
The new vEVENTQ object will need a similar function for drivers to report
the vIOMMU related events. Split the common part out to a smaller helper,
and place it in the header so that CONFIG_IOMMUFD_DRIVER_CORE can include
that in the driver.c file for drivers to use.

Then keep iommufd_fault_iopf_handler() in the header too, since it's quite
simple after all.

Reviewed-by: Kevin Tian<kevin.tian@intel.com>
Signed-off-by: Nicolin Chen<redacted>
---
  drivers/iommu/iommufd/iommufd_private.h | 20 +++++++++++++++++++-
  drivers/iommu/iommufd/fault.c           | 17 -----------------
  2 files changed, 19 insertions(+), 18 deletions(-)
Reviewed-by: Lu Baolu <baolu.lu@linux.intel.com>
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help