Thread (31 messages) 31 messages, 2 authors, 2025-01-07

Re: [PATCH v4 02/14] iommufd/fault: Add an iommufd_fault_init() helper

From: Baolu Lu <baolu.lu@linux.intel.com>
Date: 2025-01-06 02:50:50
Also in: linux-doc, linux-iommu, linux-kselftest, linux-patches, lkml

On 1/4/25 03:43, Nicolin Chen wrote:
The infrastructure of a fault object will be shared with a new vEVENTQ
object in a following change. Add a helper for a vEVENTQ allocator to
call it too.

Reorder the iommufd_ctx_get and refcount_inc, to keep them symmetrical
with the iommufd_fault_fops_release().

Since the new vEVENTQ doesn't need "response", leave the xa_init_flags
in its original location.

Reviewed-by: Kevin Tian<kevin.tian@intel.com>
Signed-off-by: Nicolin Chen<redacted>
---
  drivers/iommu/iommufd/fault.c | 48 ++++++++++++++++++++---------------
  1 file changed, 28 insertions(+), 20 deletions(-)
Reviewed-by: Lu Baolu <baolu.lu@linux.intel.com>
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help