On 2024/9/6 17:53, Krzysztof Kozlowski wrote:
On 06/09/2024 11:36, Junhao Xie wrote:
quoted
This commit adds support for Photonicat power management MCU on
Ariaboard Photonicat.
[...]
quoted
+
+ pcat_pmu_battery: supply-battery {
Drop unused labels. Everywhere. You are not making the code more readable.
I will remove them.
quoted
+ compatible = "ariaboard,photonicat-pmu-supply";
+ label = "battery";
+ monitored-battery = <&battery>;
+ power-supplies = <&pcat_pmu_charger>;
Why do you reference internal design of the device as DTS? You cannot
have here other power supply, can you?
I mistakenly thought power_supply_am_i_supplied() required power-supplies
property, it actually does not, I will remove it.
Best regards,
Krzysztof
Thanks for your review, I will fix all problems in next version!
Best regards,
Junhao