Thread (11 messages) 11 messages, 5 authors, 2024-08-08

Re: [PATCH 2/3] dt-bindings: Add power-domain header for RK3576 SoCs

From: Heiko Stübner <heiko@sntech.de>
Date: 2024-08-08 07:55:08
Also in: linux-devicetree, linux-pm, linux-rockchip, lkml

Hi Detlev,

Am Dienstag, 6. August 2024, 18:34:41 CEST schrieb Detlev Casanova:
On Sunday, 4 August 2024 05:56:39 EDT Krzysztof Kozlowski wrote:
quoted
On 02/08/2024 17:14, Detlev Casanova wrote:
quoted
From: Finley Xiao <redacted>

Define power domain IDs as described in the TRM.
Please use subject prefixes matching the subsystem. You can get them for
example with `git log --oneline -- DIRECTORY_OR_FILE` on the directory
your patch is touching. For bindings, the preferred subjects are
explained here:
https://www.kernel.org/doc/html/latest/devicetree/bindings/submitting-patche
s.html#i-for-patch-submitters
quoted
Signed-off-by: Finley Xiao <redacted>
[reword]
Signed-off-by: Detlev Casanova <detlev.casanova@collabora.com>
---

 include/dt-bindings/power/rk3576-power.h | 30 ++++++++++++++++++++++++
 1 file changed, 30 insertions(+)
 create mode 100644 include/dt-bindings/power/rk3576-power.h
This is part of bindings.
quoted
diff --git a/include/dt-bindings/power/rk3576-power.h
b/include/dt-bindings/power/rk3576-power.h
Missing vendor prefix. This should be named after compatible.
Looks like all other rockchip power bindings use the include/dt-bindings/
power/rkXXXX.h format. Should I keep that way ?
there is also rockchip,rv1126-power.h , so please follow Krzysztof's
suggestion. Older header namings need to stay the same of course
but that shouldn't keep us from updating naming schemes to better
work in new additions.


Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help