Thread (40 messages) 40 messages, 6 authors, 2022-11-13

Re: [PATCH 07/12] nvme-pci: factor out a nvme_pci_alloc_ctrl helper

From: Christoph Hellwig <hch@lst.de>
Date: 2022-11-09 06:29:04
Also in: asahi, linux-nvme

On Wed, Nov 09, 2022 at 05:03:19AM +0200, Sagi Grimberg wrote:
quoted
  -static int nvme_probe(struct pci_dev *pdev, const struct pci_device_id 
*id)
+static struct nvme_dev *nvme_pci_alloc_ctrl(struct pci_dev *pdev,
+		const struct pci_device_id *id)
kinda weird that nvme_pci_alloc_ctrl return struct nvme_dev. Patch looks
fine though...
We can call it alloc_dev instead.  But that whole nvme_dev naming is weird,
it really should be nvme_pci_ctrl.

_______________________________________________
linux-arm-kernel mailing list
linux-arm-kernel@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-arm-kernel
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help