Re: [PATCH 04/18] KVM: arm64: Move FP state ownership from flag to a tristate
From: Mark Brown <broonie@kernel.org>
Date: 2022-06-06 10:32:37
Also in:
kvm, kvmarm
From: Mark Brown <broonie@kernel.org>
Date: 2022-06-06 10:32:37
Also in:
kvm, kvmarm
On Mon, Jun 06, 2022 at 09:41:52AM +0100, Marc Zyngier wrote:
Mark Brown [off-list ref] wrote:quoted
On Sat, May 28, 2022 at 12:38:14PM +0100, Marc Zyngier wrote:
quoted
quoted
- FP_STATE_CLEAN - FP_STATE_HOST_DIRTY - FP_STATE_GUEST_DIRTY
quoted
I had to think a bit more than I liked about the _DIRTY in the names of the host and guest flags, but that's really just bikeshedding and not a meaningful issue.
Another option was:
- FP_STATE_FREE - FP_STATE_HOST_OWNED - FP_STATE_GUEST_OWNED
I don't mind wither way.
I think I do prefer that option, but like I say it's bikeshedding.