Re: [PATCH 04/18] KVM: arm64: Move FP state ownership from flag to a tristate
From: Marc Zyngier <maz@kernel.org>
Date: 2022-06-06 08:43:04
Also in:
kvm, kvmarm
From: Marc Zyngier <maz@kernel.org>
Date: 2022-06-06 08:43:04
Also in:
kvm, kvmarm
On Fri, 03 Jun 2022 10:14:11 +0100, Mark Brown [off-list ref] wrote:
On Sat, May 28, 2022 at 12:38:14PM +0100, Marc Zyngier wrote:quoted
As it turns out, this isn't really a good match for flags, and we'd be better off if this was a simpler tristate, each state having a name that actually reflect the state: - FP_STATE_CLEAN - FP_STATE_HOST_DIRTY - FP_STATE_GUEST_DIRTYI had to think a bit more than I liked about the _DIRTY in the names of the host and guest flags, but that's really just bikeshedding and not a meaningful issue.
Another option was: - FP_STATE_FREE - FP_STATE_HOST_OWNED - FP_STATE_GUEST_OWNED I don't mind wither way.
Reviewed-by: Mark Brown <broonie@kernel.org>
Thanks, M. -- Without deviation from the norm, progress is not possible. _______________________________________________ linux-arm-kernel mailing list linux-arm-kernel@lists.infradead.org http://lists.infradead.org/mailman/listinfo/linux-arm-kernel