Thread (22 messages) 22 messages, 4 authors, 2021-10-09

Re: [RFC PATCH v8 2/4] arm64: Reorganize the unwinder code for better consistency and maintenance

From: Mark Brown <broonie@kernel.org>
Date: 2021-08-26 16:24:45
Also in: live-patching, lkml

On Thu, Aug 12, 2021 at 02:06:01PM -0500, madvenka@linux.microsoft.com wrote:
Renaming of unwinder functions
==============================
Rename unwinder functions to unwind_*() similar to other architectures
for naming consistency. More on this below.
This feels like it could probably do with splitting up a bit for
reviewability, several of these headers you've got in the commit
logs look like they could be separate commits.  Splitting things
up does help with reviewability, having only one change to keep
in mind at once is a lot less cognative load.
Replace walk_stackframe() with unwind()
=======================================

walk_stackframe() contains the unwinder loop that walks the stack
frames. Currently, start_backtrace() and walk_stackframe() are called
separately. They should be combined in the same function. Also, the
loop in walk_stackframe() should be simplified and should look like
the unwind loops in other architectures such as X86 and S390.
This definitely seems like a separate change.
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help