Thread (27 messages) flat view 27 messages, 2 authors, 2021-08-02

Re: [boot-wrapper PATCH 10/12] aarch32: rename `_spin_dead` -> `err_invalid_id`

From: Andre Przywara <andre.przywara@arm.com>
Date: 2021-07-30 17:41:56

On Thu, 29 Jul 2021 16:20:48 +0100
Mark Rutland [off-list ref] wrote:
For clarity, align aarch32 with aarch64, sending unexpected CPUs to an
`err_invalid_id` loop rather than `_spin_dead`.

There should be no functional change as a result of this patch.

Signed-off-by: Mark Rutland <mark.rutland@arm.com>
Reviewed-by: Andre Przywara <andre.przywara@arm.com>

Cheers,
Andre
quoted hunk ↗ jump to hunk
---
 arch/aarch32/boot.S | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/arch/aarch32/boot.S b/arch/aarch32/boot.S
index 15e51d4..9e5c308 100644
--- a/arch/aarch32/boot.S
+++ b/arch/aarch32/boot.S
@@ -21,7 +21,7 @@ ASM_FUNC(_start)
 	cpuid	r0, r1
 	bl	find_logical_id
 	cmp	r0, #MPIDR_INVALID
-	beq	_spin_dead
+	beq	err_invalid_id
 
 	bl	setup_stack
 
@@ -58,7 +58,7 @@ _monitor:
 	/* Initialise boot method */
 	b	start_el3
 
-_spin_dead:
+err_invalid_id:
 	b	.
 
 	.text

_______________________________________________
linux-arm-kernel mailing list
linux-arm-kernel@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-arm-kernel
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help