Re: [PATCH 19/23] memory: omap-gpmc: Enclose macro statements in do-while
From: Krzysztof Kozlowski <krzk@kernel.org>
Date: 2020-07-23 10:16:42
Also in:
linux-mediatek, linux-omap, linux-tegra, lkml
On Thu, Jul 23, 2020 at 11:09:40AM +0200, Arnd Bergmann wrote:
On Thu, Jul 23, 2020 at 9:39 AM Krzysztof Kozlowski [off-list ref] wrote:quoted
do-while is a preferred way for complex macros because of safety reasons. This fixes checkpatch error: ERROR: Macros starting with if should be enclosed by a do - while loop to avoid possible if/else logic defects Signed-off-by: Krzysztof Kozlowski <krzk@kernel.org>This is an improvement, but the macro still has other issues that are just as bad as the one you address: - Using the # operator to avoid the "" in the invocation seems confusing
I guess it was useful for debugging.
- it implicitly uses the 'cs' and 't' variables of the calling function instead of passing them as arguments.
Actually another reason to convert it to just a function.
- it calls 'return -1' in a function that otherwise uses errno-style return codes, so this gets interpreted as EPERM "Operation not permitted".
The users of this macro also do it (gpmc_cs_set_timings()) so this wrong practice is consistent with the driver. :)
I would probably just open-code the entire thing and remove the
macro like:
ret = 0;
ret |= set_gpmc_timing_reg(cs, GPMC_CS_CONFIG2, 0, 3, 0, t->cs_on,
GPMC_CD_FCLK, "cs_on");
ret |= set_gpmc_timing_reg(cs, GPMC_CS_CONFIG2, 8, 12, 0,
t->cs_rd_off, GPMC_CD_FCLK, "cs_rd_off");
ret |= set_gpmc_timing_reg(cs, GPMC_CS_CONFIG2, 16, 20, 0,
t->cs_wr_off, GPMC_CD_FCLK, "cs_wr_off);
...
if (ret)
return -ENXIO;aI like this approach because it also removes the 'return' from macro which is not desired.
Of maybe leave the macro, but remove the if/return part and use the "ret |= GPMC_SET_ONE(...)" trick to avoid some of the problems.
I could probably then keep it as a function. This would be the safest and remove most of the problems here. Best regards, Krzysztof _______________________________________________ linux-arm-kernel mailing list linux-arm-kernel@lists.infradead.org http://lists.infradead.org/mailman/listinfo/linux-arm-kernel