Re: [PATCH v6 16/18] mtd: nand: Convert generic NAND bits to use the ECC framework
From: Miquel Raynal <miquel.raynal@bootlin.com>
Date: 2020-05-28 23:48:15
Also in:
linux-devicetree
From: Miquel Raynal <miquel.raynal@bootlin.com>
Date: 2020-05-28 23:48:15
Also in:
linux-devicetree
Boris Brezillon [off-list ref] wrote on Thu, 28 May 2020 18:00:03 +0200:
On Thu, 28 May 2020 13:31:11 +0200 Miquel Raynal [off-list ref] wrote:quoted
Embed a generic NAND ECC high-level object in the nand_device structure to carry all the ECC engine configuration/data. Adapt the raw NAND and SPI-NAND cores to fit the change.I would also split that one: 1/ s/nand_ecc_props/nand_ecc/ in the core + change the spi nand framework accordingly 2/ update rawnand to use the generic layer
This one I honestly don't understand how to split it. As long as I change the NAND device object content, I have to update all raw/spi-NAND devices in the same patch, or I would break the build. As it there are already many many changes, I did not split this patch. _______________________________________________ linux-arm-kernel mailing list linux-arm-kernel@lists.infradead.org http://lists.infradead.org/mailman/listinfo/linux-arm-kernel