On Wed, Jun 07, 2017 at 05:44:56PM +0800, Icenowy Zheng wrote:
? 2017?6?7? GMT+08:00 ??5:43:43, Maxime Ripard [off-list ref] ??:
quoted
On Mon, Jun 05, 2017 at 03:03:47AM +0800, Icenowy Zheng wrote:
quoted
quoted
You should also expand function sun4i_drv_node_is_tcon() at
sun4i_drv.c
quoted
quoted
with
new entries, but I'm not sure if this fits in this patch.
Instead I think it should be renamed to something like
"sun4i_drv_node_is_tcon_with_ch0".
I'm not sure, or at least, it shouldn't make any difference, since
TCON without a channel 0 will not have an endpoint 0, so this will be
dealt with already.
But that will prevent new coders from add CH1-less TCON
compatibles to this function.
Why? We already have such TCONs (like the A33's, or V3S') in that
function.
Maxime
--
Maxime Ripard, Free Electrons
Embedded Linux and Kernel engineering
http://free-electrons.com
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 801 bytes
Desc: not available
URL: <http://lists.infradead.org/pipermail/linux-arm-kernel/attachments/20170607/cf166b95/attachment.sig>