On Wed, Dec 16, 2015 at 05:08:35PM +0100, Arnd Bergmann wrote:
On Wednesday 16 December 2015 00:42:41 Yury Norov wrote:
quoted
+ sigtramp = ka->sa.sa_restorer;
+#ifdef CONFIG_ARM64_ILP32
+ else if (is_ilp32_compat_task())
+ sigtramp = VDSO_SYMBOL(current->mm->context.vdso, sigtramp_ilp32);
+#endif
+ else
+ sigtramp = VDSO_SYMBOL(current->mm->context.vdso, sigtramp);
This is another case where I think it's more readable to remove the #ifdef,
with no change in behavior.
Arnd
No actually. symbol sigtramp_ilp32 is declared in
arch/arm64/kernel/vdso-ilp32/vdso-ilp32.lds.S
And so it does not exist if CONFIG_ARM64_ILP32 is not set.