On Fri, Sep 4, 2015 at 1:57 AM, Bhupesh Sharma
[off-list ref] wrote:
Freescale will be a churning out a host of ARMv8 based SoCs which
will be based on a similar overall SoC architecture. So, this patch
converts the existing infrastructure in the arm64/dts, arm64/Kconfig
and arm64/configs to use the generic convention ARCH_LAYERSCAPE
in place of the more specific FSL_LS2085A, to save code duplication
later-on.
Also Freescale is renaming LS2085A to LS2080A.
This patch addresses the above two points.
Suggest splitting this into 2 patches because these 2 changes are really
orthogonal-- one patch for the ARCH config name change, one for the rename
ls2085a to ls2080a rename.
Not sure why you're describing it as "churning out a host of ARMv8 based SoCs".
Just get to the point-- Layerscape is an SoC family so we're changing from the
SoC specific ARCH kconfig option to a more general SoC family option.
Thanks,
Stuart