[PATCH V9 1/7] pcie: Add designware wrapper driver for SPEAr13xx
From: viresh.kumar@linaro.org (Viresh Kumar)
Date: 2014-07-14 05:01:53
Also in:
linux-pci
Subsystem:
the rest · Maintainer:
Linus Torvalds
On 11 July 2014 03:09, Bjorn Helgaas [off-list ref] wrote:
I guess I'm obsessive, but I think it's nice when people run
"git log --oneline" on the file or directory they're changing,
and then follow the existing style.
In this case, that would lead to a subject line like:
PCI: spear: Add PCIe driver for ST Microelectronics SPEAr13xxquoted
diff --git a/MAINTAINERS b/MAINTAINERS index 702ca10..443dd05 100644 --- a/MAINTAINERS +++ b/MAINTAINERS@@ -6820,6 +6820,12 @@ S: Maintained F: Documentation/devicetree/bindings/pci/host-generic-pci.txt F: drivers/pci/host/pci-host-generic.c +PCIE DRIVER FOR ST SPEAR13XX +M: Mohit Kumar <mohit.kumar@st.com> +L: linux-pci at vger.kernel.org +S: Maintained +F: drivers/pci/host/pcie-spear13xx.cWildcards work here, so you could follow the lead of IMX6, MVEBU, RCAR, and DESIGNWARE and use: F: drivers/pci/host/*spear*quoted
--- /dev/null +++ b/drivers/pci/host/pcie-spear13xx.c... +#define PCI_CAP_ID_EXP_OFFSET 0x70A nit, but I'd use a name like EXP_CAP_ID_OFFSET to make it more clear that this is specific to SPEAr, not something from the PCI specs.
Hi Bjorn, So this is how the diff looks like over this patch:
diff --git a/MAINTAINERS b/MAINTAINERS
index 443dd05..766948e 100644
--- a/MAINTAINERS
+++ b/MAINTAINERS@@ -6824,7 +6824,7 @@ PCIE DRIVER FOR ST SPEAR13XX M: Mohit Kumar <mohit.kumar@st.com> L: linux-pci at vger.kernel.org S: Maintained -F: drivers/pci/host/pcie-spear13xx.c +F: drivers/pci/host/*spear* PCMCIA SUBSYSTEM P: Linux PCMCIA Team
diff --git a/drivers/pci/host/pcie-spear13xx.cb/drivers/pci/host/pcie-spear13xx.c index a6fc332..99738e4 100644
--- a/drivers/pci/host/pcie-spear13xx.c
+++ b/drivers/pci/host/pcie-spear13xx.c@@ -139,7 +139,7 @@ struct pcie_app_reg { #define VEN_MSI_TC_MASK ((u32)0x7 << VEN_MSI_TC_ID) #define VEN_MSI_VECTOR_MASK ((u32)0x1F << VEN_MSI_VECTOR_ID) -#define PCI_CAP_ID_EXP_OFFSET 0x70 +#define EXP_CAP_ID_OFFSET 0x70 #define to_spear13xx_pcie(x) container_of(x, struct spear13xx_pcie, pp)
@@ -149,7 +149,7 @@ static int spear13xx_pcie_establish_link(structpcie_port *pp)
int count = 0;
struct spear13xx_pcie *spear13xx_pcie = to_spear13xx_pcie(pp);
struct pcie_app_reg *app_reg = spear13xx_pcie->app_base;
- u32 exp_cap_off = PCI_CAP_ID_EXP_OFFSET;
+ u32 exp_cap_off = EXP_CAP_ID_OFFSET;
if (dw_pcie_link_up(pp)) {
dev_err(pp->dev, "link already up\n");
And the subject looks like this now:
PCI: spear: Add PCIe driver for ST Microelectronics SPEAr13xx
I may skip sending a V10 for this and directly send a pull request as
there aren't any significant changes suggested in V9.
Thanks.