Thread (23 messages) flat view 23 messages, 5 authors, 2014-07-14
STALE4413d

Revision v9 of 4 in this series.

Revisions (4)
  1. v9 [diff vs current]
  2. v9 current
  3. v9 [diff vs current]
  4. v9 [diff vs current]

[PATCH V9 1/7] pcie: Add designware wrapper driver for SPEAr13xx

From: bhelgaas@google.com (Bjorn Helgaas)
Date: 2014-07-10 21:39:37
Also in: linux-pci

I guess I'm obsessive, but I think it's nice when people run
"git log --oneline" on the file or directory they're changing,
and then follow the existing style.

In this case, that would lead to a subject line like:

    PCI: spear: Add PCIe driver for ST Microelectronics SPEAr13xx

On Thu, Jul 10, 2014 at 12:56:32PM +0530, Viresh Kumar wrote:
From: Pratyush Anand <redacted>

ARM based ST Microelectronics's SPEAr1310 and SPEAr1340 SOCs have onchip
designware PCIe controller. To make that usable, this patch adds a wrapper
driver based on existing designware driver.

Adds bindings for this new driver and update MAINTAINERS as well.

Cc: linux-pci at vger.kernel.org
Acked-by: Arnd Bergmann <arnd@arndb.de>
Acked-by: Bjorn Helgaas <bhelgaas@google.com>
Acked-by: Jingoo Han <redacted>
Signed-off-by: Pratyush Anand <redacted>
Signed-off-by: Mohit Kumar <redacted>
[viresh: fixed logs/cclist/checkpatch warnings, broken into smaller patches]
Signed-off-by: Viresh Kumar <viresh.kumar@linaro.org>
quoted hunk ↗ jump to hunk
diff --git a/MAINTAINERS b/MAINTAINERS
index 702ca10..443dd05 100644
--- a/MAINTAINERS
+++ b/MAINTAINERS
@@ -6820,6 +6820,12 @@ S:	Maintained
 F:	Documentation/devicetree/bindings/pci/host-generic-pci.txt
 F:	drivers/pci/host/pci-host-generic.c
 
+PCIE DRIVER FOR ST SPEAR13XX
+M:	Mohit Kumar <mohit.kumar@st.com>
+L:	linux-pci at vger.kernel.org
+S:	Maintained
+F:	drivers/pci/host/pcie-spear13xx.c
Wildcards work here, so you could follow the lead of IMX6, MVEBU, RCAR,
and DESIGNWARE and use:

    F:	drivers/pci/host/*spear*
quoted hunk ↗ jump to hunk
--- /dev/null
+++ b/drivers/pci/host/pcie-spear13xx.c
...
+#define PCI_CAP_ID_EXP_OFFSET			0x70
A nit, but I'd use a name like EXP_CAP_ID_OFFSET to make it
more clear that this is specific to SPEAr, not something from
the PCI specs.

Bjorn
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help