On Thu, Aug 09, 2012 at 05:22:30PM -0400, Nicolas Pitre wrote:
On Thu, 9 Aug 2012, Russell King - ARM Linux wrote:
quoted
On Thu, Aug 09, 2012 at 05:12:58PM -0400, Nicolas Pitre wrote:
quoted
CFLAGS_THUMB2 should probably be renamed to something more appropriate
in this case, e.g. CFLAGS_MODE.
CFLAGS_ISA would be more relevant to it, because it's selecting the
instruction set.
Agreed. This particular TLA escaped my mind somehow.
Seems fair enough. It doesn't quite match the official architectural
terminology, but it clear enough what it means, and less cumbersome than
the alternatives.
Best not to use MODE though. That word is way too overloaded.
---Dave