Re: add file system helpers that take kernel pointers for the init code v3
From: Al Viro <viro@zeniv.linux.org.uk>
Date: 2020-07-26 16:21:26
Also in:
linux-fsdevel, linux-raid, lkml
From: Al Viro <viro@zeniv.linux.org.uk>
Date: 2020-07-26 16:21:26
Also in:
linux-fsdevel, linux-raid, lkml
On Sun, Jul 26, 2020 at 05:52:04PM +0200, Christoph Hellwig wrote:
On Sun, Jul 26, 2020 at 08:49:28AM -0700, Linus Torvalds wrote:quoted
On Sun, Jul 26, 2020 at 12:14 AM Christoph Hellwig [off-list ref] wrote:quoted
Hi Al and Linus, currently a lot of the file system calls in the early in code (and the devtmpfs kthread) rely on the implicit set_fs(KERNEL_DS) during boot. This is one of the few last remaining places we need to deal with to kill off set_fs entirely, so this series adds new helpers that take kernel pointers. These helpers are in init/ and marked __init and thus will be discarded after bootup. A few also need to be duplicated in devtmpfs, though unfortunately.I see nothing objectionable here. The only bikeshed comment I have is that I think the "for_init.c" name is ugly and pointless - I think you could just call it "fs/init.c" and it's both simpler and more straightforward. It _is_ init code, it's not "for" init.That was Al's suggestion. I personally don't care, so if between the two of you, you can come up with a preferred choice I'll switch to it.
I can live with either variant; the only problem with fs/init.c is that such name would imply the init code _of_ VFS, rather than VFS helpers for init. Anyway, the series looks generally sane; if no other objections are raised, I'm adding it to vfs.git#for-next