Re: [PATCH 04/21] devtmpfs: refactor devtmpfsd()
From: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
Date: 2020-07-26 07:43:14
Also in:
linux-fsdevel, linux-raid, lkml
From: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
Date: 2020-07-26 07:43:14
Also in:
linux-fsdevel, linux-raid, lkml
On Sun, Jul 26, 2020 at 09:13:39AM +0200, Christoph Hellwig wrote:
Split the main worker loop into a separate function. This allows devtmpfsd itself and devtmpfsd_setup to be marked __init, which will allows us to call __init routines for the setup work. Signed-off-by: Christoph Hellwig <hch@lst.de> --- drivers/base/devtmpfs.c | 47 +++++++++++++++++++++++------------------ 1 file changed, 26 insertions(+), 21 deletions(-)
Nice cleanup, thanks for doing this: Reviewed-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>