Thread (30 messages) flat view 30 messages, 4 authors, 2020-07-26

Re: [PATCH 04/21] devtmpfs: refactor devtmpfsd()

From: Christoph Hellwig <hch@lst.de>
Date: 2020-07-26 08:21:24
Also in: linux-fsdevel, linux-raid, lkml

On Sun, Jul 26, 2020 at 09:43:06AM +0200, Greg Kroah-Hartman wrote:
On Sun, Jul 26, 2020 at 09:13:39AM +0200, Christoph Hellwig wrote:
quoted
Split the main worker loop into a separate function.  This allows
devtmpfsd itself and devtmpfsd_setup to be marked __init, which will
allows us to call __init routines for the setup work.

Signed-off-by: Christoph Hellwig <hch@lst.de>
---
 drivers/base/devtmpfs.c | 47 +++++++++++++++++++++++------------------
 1 file changed, 26 insertions(+), 21 deletions(-)
Nice cleanup, thanks for doing this:
This was actualy Als idea, I should have probably mentioned that.
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help