On 10/02/2018 09:21 AM, Yu-cheng Yu wrote:
On Tue, 2018-10-02 at 17:29 +0200, Borislav Petkov wrote:
quoted
On Fri, Sep 21, 2018 at 08:03:26AM -0700, Yu-cheng Yu wrote:
quoted
To support XSAVES system states, change some names to distinguish
user and system states.
I don't understand what the logic here is. SDM says:
XSAVES—Save Processor Extended States Supervisor
the stress being on "Supervisor" - why does it need to be renamed to
"system" now?
Good point. However, "system" is more indicative; CET states are per-task and
not "Supervisor". Do we want to go back to "Supervisor" or add comments?
This is one of those things where the SDM language does not match what
we use in the kernel. I think it's fine to call them "system" or
"kernel" states to make it consistent with our existing in-kernel
nomenclature.
I say add comments to clarify what the SDM calls it vs. what we do.