Re: [PATCH 01/11] fs: add O_BENEATH_ONLY flag to openat(2)
From: Meredydd Luff <hidden>
Date: 2014-07-08 12:48:51
Also in:
linux-man, lkml
From: Meredydd Luff <hidden>
Date: 2014-07-08 12:48:51
Also in:
linux-man, lkml
On 8 July 2014 13:07, Christoph Hellwig [off-list ref] wrote:
There's two different AT_* namespaces. The flags that most *at syscalls has, and the the one for the dfd argument, which currently only contains AT_FDCWD, although a new constant has recently been proposed to it. Having an AT_BENEATH magic value for the dfd argument certainly feels elegant to me
How would that work? The directory beneath which openat is looking is conveyed in the dfd argument itself. If I'm understanding this right, you'd have to pass a different value for "open relative to fd#5" and "open relative to fd#5, but beneath it only", which doesn't sound hugely elegant to me. Meredydd