Re: [PATCH 5/8] builtin/pack-objects: simplify logic to find kept or nonlocal objects
From: Toon Claes <hidden>
Date: 2025-10-29 14:55:45
Patrick Steinhardt [off-list ref] writes:
The function `has_sha1_pack_kept_or_nonlocal()` takes an object ID and then searches through packed objects to figure out whether the object exists in a kept or non-local pack. As a performance optimization we remember the packfile that contains a given object ID so that the next call to the function first checks that same packfile again. The way this is written is rather hard to follow though, as the caching mechanism is intertwined with the loop that iterates through the packs. Consequently, we need to do some gymnastics to re-start the iteration if the cached pack does not contain the objects.
Okay, this took me while, but yes this function was really hard to understand. Thanks for simplifying. Naive question, what's the point of keeping a "last_found"? We have one global "last_found" for the last time this function was called, and we have no control which OIDs get passed to this function. Why look into "last_found" first?
quoted hunk ↗ jump to hunk
Refactor this so that we check the cached packfile at the beginning. We don't have to re-verify whether the packfile meets the properties as we have already verified those when storing the pack in `last_found` in the first place. So all we need to do is to use `find_pack_entry_one()` to check whether the pack contains the object ID, and to skip the cached pack in the loop so that we don't search it twice. This refactoring significantly simplifies the logic and makes it much easier to follow. Signed-off-by: Patrick Steinhardt <redacted> --- builtin/pack-objects.c | 26 +++++++++++++------------- 1 file changed, 13 insertions(+), 13 deletions(-)diff --git a/builtin/pack-objects.c b/builtin/pack-objects.c index 5348aebbe9f..861fef3f38a 100644 --- a/builtin/pack-objects.c +++ b/builtin/pack-objects.c@@ -4388,27 +4388,27 @@ static void add_unreachable_loose_objects(struct rev_info *revs) static int has_sha1_pack_kept_or_nonlocal(const struct object_id *oid) { - struct packfile_store *packs = the_repository->objects->packfiles; static struct packed_git *last_found = (void *)1; struct packed_git *p; - p = (last_found != (void *)1) ? last_found : - packfile_store_get_packs(packs); + if (last_found != (void *)1 && find_pack_entry_one(oid, last_found)) + return 1; - while (p) { - if ((!p->pack_local || p->pack_keep || - p->pack_keep_in_core) && - find_pack_entry_one(oid, p)) { + repo_for_each_pack(the_repository, p) { + if ((!p->pack_local || p->pack_keep || p->pack_keep_in_core) && + find_pack_entry_one(oid, p)) { last_found = p; return 1; } - if (p == last_found) - p = packfile_store_get_packs(packs); - else - p = p->next; - if (p == last_found) - p = p->next; + + /* + * We have already checked `last_found`, so there is no need to + * re-check here. + */
I had to reason with myself why you need to extra `(void *)1` check, maybe you can extend the comment a bit: /* * When `last_found` was set to something else then * `(void *)1` we have already checked it, * so there is no need to re-check here. */
+ if (p == last_found && last_found != (void *)1) + continue;
-- Cheers, Toon