Re: [PATCH v3 2/2] [Outreachy][Patch v1] t3404: employing test_line_count() to replace test
From: Eric Sunshine <hidden>
Date: 2024-10-07 04:38:22
From: Eric Sunshine <hidden>
Date: 2024-10-07 04:38:22
On Sun, Oct 6, 2024 at 12:06 PM Usman Akinyemi via GitGitGadget [off-list ref] wrote:
Refactor t3404 to replace instances of `test` with `test_line_count()` for checking line counts. This improves readability and aligns with Git's current test practices. Signed-off-by: Usman Akinyemi <redacted> ---diff --git a/t/t3404-rebase-interactive.sh b/t/t3404-rebase-interactive.sh@@ -281,7 +281,8 @@ test_expect_success 'stop on conflicting pick' ' - test 4 = $(grep -v "^#" < .git/rebase-merge/done | wc -l) && + grep -v "^#" < .git/rebase-merge/done > actual && + test_line_count = 4 actual &&
Thanks. Both patches in this series look fine. Let's consider this a successfully-completed microproject.