Re: [PATCH v2 5/7] rebase: drop support for `--preserve-merges`
From: Johannes Schindelin <hidden>
Date: 2021-09-02 13:59:37
Hi Ævar, On Wed, 1 Sep 2021, Ævar Arnfjörð Bjarmason wrote:
On Wed, Sep 01 2021, Johannes Schindelin via GitGitGadget wrote:quoted
From: Johannes Schindelin <redacted> This option was deprecated in favor of `--rebase-merges` some time ago, and now we retire it.quoted
static int is_merge(struct rebase_options *opts) { - return opts->type == REBASE_MERGE || - opts->type == REBASE_PRESERVE_MERGES; + return opts->type == REBASE_MERGE; }This leaves us with a rather pointless is_merge() function and nonsensical control flow in parse_opt_merge().
Thank you for offering your perspective. From a readability point of view, I disagree with your assessment. Just because it can be written shorter does not mean that it is clearer. Quite the contrary, if you ask me. And since _I_ am contributing this patch series, I will respectfully disagree and keep the version I find more intuitive. You could potentially talk me into adding a patch that renames that function to `is_merge_backend()`, but that's as far as I would go. And I am not really certain that that would improve things, either. Ciao, Dscho