Re: [PATCH 3/9] rename "alternate_object_database" to "object_directory"
From: Jeff King <hidden>
Date: 2018-11-12 15:36:04
On Mon, Nov 12, 2018 at 10:30:55AM -0500, Derrick Stolee wrote:
On 11/12/2018 9:48 AM, Jeff King wrote:quoted
In preparation for unifying the handling of alt odb's and the normal repo object directory, let's use a more neutral name. This patch is purely mechanical, swapping the type name, and converting any variables named "alt" to "odb". There should be no functional change, but it will reduce the noise in subsequent diffs. Signed-off-by: Jeff King <redacted> --- I waffled on calling this object_database instead of object_directory. But really, it is very specifically about the directory (packed storage, including packs from alternates, is handled elsewhere).That makes sense. Each alternate makes its own object directory, but is part of a larger object database. It also helps clarify a difference from the object_store. My only complaint is that you have a lot of variable names with "odb" which are now object_directory pointers. Perhaps "odb" -> "objdir"? Or is that just too much change?
Yeah, that was part of my waffling. ;) From my conversions, usually "objdir" is a string holding the pathname, though that's not set in stone. I also like that "odb" is the same short length as "alt", which helps with conversion. But I dunno. -Peff