Re: [PATCH v7 12/31] merge-recursive: move the get_renames() function
From: Stefan Beller <hidden>
Date: 2018-02-02 23:27:54
On Tue, Jan 30, 2018 at 3:25 PM, Elijah Newren [off-list ref] wrote:
I want to re-use some other functions in the file without moving those other functions or dealing with a handful of annoying split function declarations and definitions.
git log --grep "I want" --format="%ad %an %s"
Nowadays we write commit messages slightly differently, more
passively, but I let others comment on the wording of the commit
message if they feel inclined to do so. I can fully understand what
this commit is all about.
+ struct string_list_item *item;
+ struct rename *re;
+ struct diff_filepair *pair = diff_queued_diff.queue[i];
+
+ if (pair->status != 'R') {It is not an exact move, you snuck in an empty line between the variable declarations and this condition. :) No big deal, actually I like it for readability. (related https://public-inbox.org/git/CAGZ79kZX2FsEjD04zr5-oufU6dLhiOhBkxv4u8VEwL0OPRFtiA@mail.gmail.com/) Thanks, Stefan