Thread (8 messages) 8 messages, 5 authors, 2017-10-25

Re: [PATCH] merge-recursive: check GIT_MERGE_VERBOSITY only once

From: Andrey Okoshkin <hidden>
Date: 2017-10-25 10:49:52

Possibly related (same subject, not in this thread)

Thanks for your review.

24.10.2017 19:28, Stefan Beller wrote:
So I think this function is never called from within a threaded environment
in git.
You are right, it's just a hypothetic case.
 
Despite not being in a threaded environment, I wonder if we want to
minimize the time between  calling getenv and the use of the result,
i.e. declare merge_verbosity here, but assign it later, just before the
condition?

(The compiler may shuffle stuff around anyway, so this is a
moot suggestion; It gears mostly towards making the code more
readable/maintainable when presenting this part of the code
to the user.)

With or without this change:
Reviewed-by: Stefan Beller <redacted>
Yes, in current situation it's more for readability. And I'll make the usage
of merge_verbosity just after the assignment.

-- 
Best regards,
Andrey Okoshkin
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help