Thread (60 messages) read the whole thread 60 messages, 6 authors, 2017-08-17

Re: [PATCH 0/5] make interpret-trailers useful for parsing

From: Jeff King <hidden>
Date: 2017-08-10 18:03:32

On Thu, Aug 10, 2017 at 04:02:46AM -0400, Jeff King wrote:
On Wed, Aug 09, 2017 at 08:21:47AM -0400, Jeff King wrote:
quoted
This series teaches interpret-trailers to parse and output just the
trailers. So now you can do:

  $ git log --format=%B -1 8d44797cc91231cd44955279040dc4a1ee0a797f |
    git interpret-trailers --parse
  Signed-off-by: Hartmut Henkel [off-list ref]
  Helped-by: Stefan Beller [off-list ref]
  Signed-off-by: Ralf Thielow [off-list ref]
  Acked-by: Matthias Rüster [off-list ref]
And here's a v2 that addresses all of the comments except one: Stefan
suggested that --only-existing wasn't a great name. I agree, but I like
everything else less.
Here's a v3 that takes care of that (renaming it to --only-input).

It's otherwise the same as v2, but since the name-change ripples through
the remaining patches, I wanted to get v3 in front of people sooner
rather than later.

  [1/5]: trailer: put process_trailers() options into a struct
  [2/5]: interpret-trailers: add an option to show only the trailers
  [3/5]: interpret-trailers: add an option to show only existing trailers
  [4/5]: interpret-trailers: add an option to normalize output
  [5/5]: interpret-trailers: add --parse convenience option

 Documentation/git-interpret-trailers.txt | 34 +++++++++++---
 builtin/interpret-trailers.c             | 34 +++++++++++---
 t/t7513-interpret-trailers.sh            | 76 ++++++++++++++++++++++++++++++++
 trailer.c                                | 68 ++++++++++++++++++++++------
 trailer.h                                | 13 +++++-
 5 files changed, 196 insertions(+), 29 deletions(-)
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help