Jeff King [off-list ref] writes:
On Thu, Mar 16, 2017 at 03:43:13PM -0700, Junio C Hamano wrote:
quoted
Jeff King [off-list ref] writes:
quoted
+ifdef USE_SHA1DC
+ LIB_OBJS += sha1dc/sha1.o
+ LIB_OBJS += sha1dc/ubc_check.o
+ BASIC_CFLAGS += -DSHA1_SHA1DC
The name of this CPP symbol is one difference between this and
Linus's version. Wouldn't "-DSHA1_DC" make more sense?
I'm fine with either. Somehow SHA1_DC felt too short, but it doesn't
really matter in practice.
I'm fine with either, too. It was just double SHA1 felt a bit
strange, when the naming convention was SHA1_ followed by the
characteristic attribute of the implementation (e.g. came from
Mozilla, etc.) and I thought "Detecting Collision" was the notable
characteristic of this one.
quoted
Another difference is that your version adds USE_SHA1DC to
GIT-BUILD-OPTIONS in patch 5/5; I thought GIT-CFLAGS forces
rebuilding and that was sufficient, but GIT-BUILD-OPTIONS is
available to tests for introspection, so adding it is needed
for that reason.
Yep, exactly.
Thanks.