On Fri, Mar 17, 2017 at 10:09:35AM -0700, Junio C Hamano wrote:
Here are three patches to replace the last two patches from your
series.
- The Makefile knob is named DC_SHA1, not USE_SHA1DC; this is to
keep it consistent with existing BLK_SHA1 and PPC_SHA1.
- The CPP macro is called SHA1_DC, not SHA1_SHA1DC; again this is
for consistency with SHA1_BLK and SHA1_PPC.
- Switch the default from OpenSSL's implementation to DC_SHA1.
Those who want OpenSSL's one can ask with OPENSSL_SHA1.
OK. DC_SHA1 exposed tothe user does look a little funny to me, but it is
at least consistent with the other names. The patches themselves look
obviously fine.
-Peff