Jeff King [off-list ref] writes:
+ifdef USE_SHA1DC
+ LIB_OBJS += sha1dc/sha1.o
+ LIB_OBJS += sha1dc/ubc_check.o
+ BASIC_CFLAGS += -DSHA1_SHA1DC
The name of this CPP symbol is one difference between this and
Linus's version. Wouldn't "-DSHA1_DC" make more sense?
Another difference is that your version adds USE_SHA1DC to
GIT-BUILD-OPTIONS in patch 5/5; I thought GIT-CFLAGS forces
rebuilding and that was sufficient, but GIT-BUILD-OPTIONS is
available to tests for introspection, so adding it is needed
for that reason.