Re: [PATCH v4 1/2] lib-proto-disable: variable name fix
From: Jeff King <hidden>
Date: 2016-11-07 20:48:45
On Mon, Nov 07, 2016 at 12:40:28PM -0800, Brandon Williams wrote:
On 11/07, Jeff King wrote:quoted
On Mon, Nov 07, 2016 at 11:35:22AM -0800, Brandon Williams wrote:quoted
Small fix to use '$desc' instead of '$1' in lib-proto-disable.sh.Even for a trivial fixup like this, I think it's good to say why. Because what seems trivial and obvious to you while working on the patch may not be so to a reviewer, or somebody reading it 6 months later. Just something simple like: The test_proto function assigns the positional parameters to named variables, but then still refers to "$desc" as "$1". Using $desc is more readable and less error-prone. -PeffAlright will do. Commit messages don't seem to be an area of strength for me, but I'm working on it! :D
It's possible that I'm overly picky about my commit messages, but that does not stop me from trying to train an army of picky-commit-message clones. :) -Peff