Thread (99 messages) flat view 99 messages, 7 authors, 2016-12-15

Re: [PATCH v4 1/2] lib-proto-disable: variable name fix

From: Brandon Williams <hidden>
Date: 2016-11-07 20:47:57

On 11/07, Jeff King wrote:
On Mon, Nov 07, 2016 at 11:35:22AM -0800, Brandon Williams wrote:
quoted
Small fix to use '$desc' instead of '$1' in lib-proto-disable.sh.
Even for a trivial fixup like this, I think it's good to say why.
Because what seems trivial and obvious to you while working on the patch
may not be so to a reviewer, or somebody reading it 6 months later.

Just something simple like:

  The test_proto function assigns the positional parameters to named
  variables, but then still refers to "$desc" as "$1". Using $desc is
  more readable and less error-prone.

-Peff
Alright will do.  Commit messages don't seem to be an area of strength
for me, but I'm working on it! :D

-- 
Brandon Williams
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help