Thread (34 messages) flat view 34 messages, 5 authors, 2016-07-21

Re: [PATCH v1 2/6] Status and checkout unit tests for --porcelain[=<n>]

From: Jeff Hostetler <hidden>
Date: 2016-07-20 17:33:57


On 07/20/2016 12:03 PM, Jeff King wrote:
On Wed, Jul 20, 2016 at 10:00:07AM -0600, Jeff King wrote:
quoted
On Tue, Jul 19, 2016 at 06:10:54PM -0400, Jeff Hostetler wrote:
quoted
+test_expect_failure '--porcelain=bogus with stuff to commit returns ok' '
+	echo bongo bongo bongo >>file &&
+	git commit -m next -a --porcelain=bogus
+'
Hrm. That seems unexpected to me. Shouldn't it complain about
--porcelain=bogus?
Pondering more, did you mean:

   test_expect_success '--porcelain=bogus complains about format' '
	echo bongo bongo bongo >>file &&
	test_must_fail git commit -m next -a --porcelain=bogus
   '

?
Yes.  That is what I meant.  And yes, some of the names are confusing.
Thanks.

Jeff
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help