[PATCH v5 3/6] builtin/verify-tag: change variable name for readability
From: <hidden>
Date: 2016-06-16 02:18:40
Subsystem:
the rest · Maintainer:
Linus Torvalds
From: Santiago Torres <redacted> The run_gpg_verify function has two variables size, and len. This may come off as confusing when reading the code. We clarify which one pertains to the length of the tag headers by renaming len to payload_length. Signed-off-by: Santiago Torres <redacted> --- builtin/verify-tag.c | 11 ++++++----- 1 file changed, 6 insertions(+), 5 deletions(-)
diff --git a/builtin/verify-tag.c b/builtin/verify-tag.c
index 77f070a..1ca9a05 100644
--- a/builtin/verify-tag.c
+++ b/builtin/verify-tag.c@@ -21,20 +21,21 @@ static const char * const verify_tag_usage[] = { static int run_gpg_verify(const char *buf, unsigned long size, unsigned flags) { struct signature_check sigc; - int len; + int payload_size; int ret; memset(&sigc, 0, sizeof(sigc)); - len = parse_signature(buf, size); + payload_size = parse_signature(buf, size); - if (size == len) { + if (size == payload_size) { if (flags & GPG_VERIFY_VERBOSE) - write_in_full(1, buf, len); + write_in_full(1, buf, payload_size); return error("no signature found"); } - ret = check_signature(buf, len, buf + len, size - len, &sigc); + ret = check_signature(buf, payload_size, buf + payload_size, + size - payload_size, &sigc); print_signature_buffer(&sigc, flags); signature_check_clear(&sigc);
--
2.8.0