Re: [PATCH v3 0/5] cleanup duplicate name_compare() functions
From: Jeremiah Mahler <hidden>
Date: 2016-06-15 23:01:41
Jonathan, On Wed, Jun 18, 2014 at 12:14:07PM -0700, Jonathan Nieder wrote:
Jeremiah Mahler wrote:quoted
Jeremiah Mahler (5): cache: rename cache_name_compare() to name_compare() tree-walk.c: remove name_compare() function unpack-trees.c: remove name_compare() function dir.c: rename to name_compare() name-hash.c: rename to name_compare() cache.h | 2 +- dir.c | 3 +-- name-hash.c | 2 +- read-cache.c | 23 +++++++++++++---------- tree-walk.c | 10 ---------- unpack-trees.c | 11 ----------- 6 files changed, 16 insertions(+), 35 deletions(-)After looking at the patches I suspect this should be a single patch. That way it's bisectable, and the changes outside of read-cache.c are small enough that it's not too much of a burden to review as a single patch.
That would be a pain to bisect if the partial application of the patch set left the system in a broken state. Good suggestion.
The code change looked good. Thanks and hope that helps, Jonathan
Thanks, -- Jeremiah Mahler jmmahler@gmail.com http://github.com/jmahler