"Gary V. Vaughan" [off-list ref] writes:
By default the testsuite calls 'diff -u' whenever a file comparison is
called for. Unfortunately that throws a "diff: unknown option '-u'"
error for most non-GNU diffs.
This patch sets GIT_TEST_CMP to 'cmp' on all the architectures where
that happens.
Wouldn't most of these platforms you listed have a working "diff -c" at
least? Using it would make debugging the tests easier, as it would be
more readable than output from "cmp".
I also saw your patch to install-webdoc used "$DIFF -u"; as the patch
series seem to assume a unified-capable diff implementation is available
somewhere, perhaps you do not need this patch after all, but instead just
need to default GIT_TEST_CMP to "$DIFF -u" in t/test-lib.sh, no?