[Buildroot] [PATCH 06/15] package/pkg-generic.mk: Introduce <PKG>_PER_PACKAGE_TWEAK_HOOKS
From: Herve Codina <herve.codina@bootlin.com>
Date: 2021-07-02 07:18:55
Hi Yann, All On Fri, 25 Jun 2021 09:21:20 +0200 Herve Codina [off-list ref] wrote:
Hi, On Tue, 22 Jun 2021 22:39:09 +0200 "Yann E. MORIN" [off-list ref] wrote:quoted
quoted
$(call fixup-libtool-files,$(NAME),$(STAGING_DIR)) + $(foreach hook,$($(PKG)_PER_PACKAGE_TWEAK_HOOKS),$(call $(hook))$(sep))I am going to bikeshed on the naming of this variable (which is a good sing that I am pretty much OK with the feature). I think $(2)_EARLY_PRE_CONFIGURE_HOOKS is more sensible.That's good for me. Okay for everyone ?
The more I read the code, the more I think $(2)_EARLY_PRE_CONFIGURE_HOOKS is not a good name. Actions done in this hook are for package preparation. Yann talks about $(2)-prepare step and even if this step is not implemented as a buildroot step (.stamp_xxxxxx) this is really a package preparation. Indeed, we prepare the package for the next step (retrieving dependencies files for per-package host and target dir) and finally we do the fixups. Once done, the package is ready and so we take the snapshot for overwrite detection. What do you think about $(2)_POST_PREPARE_HOOKS ? Regards, Herv? -- Herv? Codina, Bootlin Embedded Linux and Kernel engineering https://bootlin.com