Thread (3 messages) 3 messages, 3 authors, 2026-09-15

Re: [PATCH net-next v2] octeontx2-af: consolidate RVU AFVF device id definitions

flat view

From: patchwork-bot+netdevbpf@kernel.org
Date: 2026-09-15 02:31:15
Also in: lkml

Hello:

This patch was applied to netdev/net-next.git (main)
by Jakub Kicinski [off-list ref]:

On Thu, 10 Sep 2026 18:41:02 +0800 you wrote:
commit f695390ea639 ("octeontx2-af: Fix limiting SRIOV VF count logic")
added a local PCI_DEVID_OCTEONTX2_RVU_AFVF define in rvu.c, although
the same value was already defined twice elsewhere: as RVU_LBK_VF_DEVID
in af/rvu.h and as PCI_DEVID_OCTEONTX2_RVU_AFVF in nic/otx2_common.h.

Move the definition into the "PCI device IDs" block in af/rvu.h, rename
RVU_LBK_VF_DEVID to match the PCI_DEVID_* naming convention of its
peers, and drop the redundant copies in rvu.c and nic/otx2_common.h,
the latter already including <rvu.h> through the af include path.

[...]
Here is the summary with links:
  - [net-next,v2] octeontx2-af: consolidate RVU AFVF device id definitions
    https://git.kernel.org/netdev/net-next/c/ce71c433395e

You are awesome, thank you!
-- 
Deet-doot-dot, I am a bot.
https://korg.docs.kernel.org/patchwork/pwbot.html

Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help