On Thu, Sep 10, 2026 at 06:41:02PM +0800, Jiangshan Yi wrote:
commit f695390ea639 ("octeontx2-af: Fix limiting SRIOV VF count logic")
added a local PCI_DEVID_OCTEONTX2_RVU_AFVF define in rvu.c, although
the same value was already defined twice elsewhere: as RVU_LBK_VF_DEVID
in af/rvu.h and as PCI_DEVID_OCTEONTX2_RVU_AFVF in nic/otx2_common.h.
Move the definition into the "PCI device IDs" block in af/rvu.h, rename
RVU_LBK_VF_DEVID to match the PCI_DEVID_* naming convention of its
peers, and drop the redundant copies in rvu.c and nic/otx2_common.h,
the latter already including <rvu.h> through the af include path.
No functional change.
Signed-off-by: Jiangshan Yi <redacted>
Acked-by: Ratheesh Kannoth <rkannoth@marvell.com>
---
Changes in v2:
- also drop the duplicate PCI_DEVID_OCTEONTX2_RVU_AFVF define in
nic/otx2_common.h, which already includes <rvu.h>, so that all three
definitions of this device id are consolidated into af/rvu.h
(suggested by the Sashiko netdev review).
Link: https://lore.kernel.org/r/20260908094051.666769-1-yijiangshan@kylinos.cn (local)
Reviewed-by: Simon Horman <horms@kernel.org>